Starting Tips | Ask Questions | Introductions | Categories

Update firmware on the vesc w/ windows

hello all i am trying to update my vesc to v2.3 i am at v1.14 now. when i open the new version of the bldc tool for windows and connect i get this message

so i go to the firmware tab and in the update new firm ware section i hit the choose button and this pops up

i tried opening all of these but could not get any firmware updates. how can i update the firmware on the vesc using the windows version of the bldc tool?

careful. I ended up only partially updating the firmware w/ BLDC tool (windows port) and when it hung/failed it was D.E.D.

Until i hooked up a programmer board in linux and reflashed to latest. I was trying to go from 1.10 to 1.13 at the time.

As an insurance policy do you have a programming board? (ST-LINK v2?) Linux system to use if ported version doesn’t work?

2 Likes

I remember reading somewhere that you should update the firmware on the VESC before running the new version of the BLDC.

I’m interested in this thread topic, and was actually going to make one right now had I not seen yours!

Haha I really want FOC, but I don’t trust myself to successfully update everything…

the update was very and quick - I used the OS X version that jaccobloy compiled. The new versions are actually v2.4 firmware and app.

did you ever figure this out @locktight ? i have the same problem with the windows version

i haven’t figured it out. i still need to try a few things but what you have done is probably what i am going to try. it hasn’t been high on my priority due to the snow. i might be able to try tomorrow. Merry Christmas everyone! :smile:

merry christmas bro. i just got an rc remote for a temp controller so i can get riding. just need to button it up now

A Warning about updating VESC firmware!!

Quote By: Benjamin Vedder. Using the wrong firmware will most likely kill the FETs and/or the drv, so when you change firmware you should use some kind of power supply that cannot deliver too much current at first and preferably a low voltage (<20 V).

Only attempt to change the firmware if you are aware of the risks. A failed firmware upgrade can permanently damage the VESC. The enertion warranty doesn’t cover faults relating to failed firmware upgrades.

Try this version of BLDC tool as it is compatible with the firmware of December Batch of Enertion VESC https://drive.google.com/file/d/0B4M52aF7FaMWM2lsalBNbjlWNWM/view?usp=sharing

The folders in that link don’t seem to contain the actual .bin firmware files, which is what @locktight was asking in his original post.

Here’s a link from @jacobbloy which will lead you to all versions of the BLDC tool. I found this very useful.

LINK TO ALL VERSIONS OF BLDC TOOL

Here’s what worked for me:

  • dowload the 2.7 version
  • connect vesc to reliable power supply
  • connect the VESC to USB and let BLDC tell you the firmware is old
  • go to firmware tab, select “choose”
  • navigate to folder “firmwares 2.7 FOC” and then the folder for
    your hardware version (written on your Vesc, right next to the PPM
    pins)
  • select “default.bin”
  • update firmware
  • done
2 Likes

Is there a version compatible with FOC 2.8 that was recently sent out? I’m totally scared to update the firmware or mess with the VESC.

With the VESC, we usually don’t recommend trying to update and change the firmware unless you know exactly what you are doing. It isn’t too terribly difficult, but if you were to incorrectly update it, your VESC very well could be dead.

Are you asking what windows version is compatible with FOC 2.8, or which VESC PCB is compatible?

For the windows versions, check out this thread:

well i tried upgrading firmware again today and ran into some issues.i first tried updating on the newest version of the bldc tool but it could not update due to the older firmware on my vescs. next i tried downloading the firmware from that bldc tool using an older version. it starts by saying buffer erase under the loading bar but it then switches to buffer erase timeout, and doesn’t do anything. any suggestions on how i go about fixing this?

Hello locktight…just wanted to know if you managed to fix the upgrading firmware issue? I have exactly the same problem with my version 4.12 VESC trying to upgrade from 2.15 to 2.17 - 2.18 issue and I have no idea what to do. Cheers, Alex

Hi!
How did you manage your problem with 4.12 VESC trying to upgrade from 2.15 to 2.17 - 2.18 issue? I have same situation now.

so im doing my first build for learning purposes but im in this situation i got my 4.12 VESC with firmware 2.18 and i got the windows BLDC-Tool ACKMANIAC mod 2,53 and it says the connected vesc has too old of a firmware… should i get an older bldc tool or update the firmware of my VESC. and where do i get the firmware or the tool cuz the older tool i got is the 2.52 from ackamniac :disappointed_relieved: would really appreciate the help PS: i got my vesc motor receiver and controller all hooked up and the vesc is powering the motor and i can control it with the remote so at least i got the remote pairing thing right i guess :smile: any help would be deeply appreciated

@ackmaniac could probably help you

To use my modded bldc-tool you have to flash the vesc with my firmware mod which can Fiat the same Dropbox link.