VESC Firmware update

I got 2 VESC from enertion’s August build, they came with the firmware version 1.10

Now I am trying to update to update to 1.13, the BLDC tool only works with 1.13… What to do? do I need the BLDC tool that is compatible with 1.10 and use it to upload the 1.13 firmware? (chiken or the egg kind of thing)

My other option is to go through the SWD cable, which is a PITA, my discovery board is at work, 1hr away, kinda hoping to get away with this update via USB.



mate you can use the bloc 1.13 software to update the esc.

when i update the windows and mac software i use the latest software to update the vesc, but if you need the old version then just download it to from my google drive.

@Blasto I would love to know this as well. I couldn’t find a version of BLDC Tool for Windows that would read my VESC’s firmware. It just reads “old firmware.”

@Blasto does BLDC read your firmware version?

I’m wondering if there is any firmware installed on this shipment of VESC. @cmatson was your August Enertion VESC shipped with firmware installed?

Yes they come with firmware installed.

So go plug in your vesc into the latest version of BLDC tool, then click the firmware tab, once your in the tap, there will be a button for you to choose the latest firmware, then can also be downloaded from my google drive link I posted above or direct from here

You click the default.dll file I think it is and then click upload, wait maybe 30 seconds and bam your vesc will know work with BLDC tool.

If you don’t want to update the firmware (not recommended) then just down load BLDC Tool fW 1.10 here is the link exactly to that version or get it from the first link I posted.

ya, mine came pre loaded with v1.10, and I have just used the v1.10 BLDC tool.

In the BLDC tool, I click on the firmware tab, i choose the proper bin file. /BLDC/BLDC/bldc-tool/firmwares/hw_46_47/VESC_default.bin

hit upload, the progress bar progresses to the end, the usb disconnects, then I power cycle the VESC, reconnect the USB… still version 1.10 :\

@jacobbloy i’ll try out your links and let you know the results


@treenutter yes I am able to read the FW version, sadly I can’t post a screen shot being a new user and all.

im using ubuntu, i’ll try the windows version

1 Like

Same here, it’s locked at FW1.10. Tried it with Ubuntu, OSX and Win, but after reconnect it’s still on 1.10. Doesn’t accept anything else above.

At the end it’s not s big thing to stay with it that way and using BLDC on 1.10, but the Enertion VESC is the only one I have which is behaving like this (I have some more from Benjamin and Marcin too).

Same thing here. Tried in Ubuntu 14.04 and Windows. Says firmware finished uploading, then I can no longer connect to the board. Have to remove power (not just usb). When I reapply power and reconnect, it is still at v1.10. I’m going to try it with the other 3 I bought, but I’m not too hopeful. I’ll just use v1.10 for now then. Glad someone posted this, I was really banging my head against the wall thinking I was the only one who couldn’t get these to work.

So i tried with the windows version of the BLDC tool, same result, stuck at 1.10

Drove to work, picked up my discovery board, drove back and success! now at FW 1.13, through the SWD

I did have to retry a couple of times when I loaded the bootloader, maybe this could be the issue, the bootloader was not properly flashed?

I would say it is that the bootloader didn’t flash, I have some very cheap stlinkv2 I can get if any one needs it!

One thing I could suggest is to try BLDC tool 10.12 or BLDC tool 10.10 to try and load the newer firmware, it could be an error with BLDC tool version 1.13! But I think it’s the bootloader! If any one doesn’t have the ability to install Linux but is OK buying a cheap stlinkv2 (good thing to have with the vesc! ) then I have access to software that I can load the bootloader for you!

1 Like

@Blasto I figured out my issue; I was using an unsupported version of windows (my “shop” laptop that I don’t care for very well). Once I tried on Windows 8.1, BLDC Tool recognized my VESC and its firmware.

Thx @cmatson; this was a very helpful clue!

@elkick @Blasto @jacobbloy @jgeating I’ve got the same issue with the same VESC; I can’t seem to update the firmware. I’ll try with BLDC Tool 10.12 and 10.10 later tonight; it definitely didn’t work w BLDC Tool 10.13.

@treenutter if you’re able to get your hands on a discovery board and flash only the bootloader, then try to update the fw using the bldc tool, the root cause would be isolated.

I ordered a stlink v2 locally and will try it as soon as it arrives. FW1.10 works good, but I’d like to be able to update to future versions. :smile:

1 Like

Thx @Blasto I’m looking for the changelog to see if there is anything significant in 1.13 that I need. So far 1.10 is working very well; although I’d hate to miss out on all the future updates. Updating VESC with new additions is going to be half of the fun I think!

@elkick please let us know how it turns out.

hi every one, jason is on holidays but we have to apologise that the bootloader is the problem, when uploading 100+ esc’s a few of them didn’t upload correctly, as i have said if you can not install linux i can upload it for you remotely but you will need an stlinkv2 i have about 10 in stock and i can send you one free just pay for shipping.

Received the stlinkv2 today and it took me just 10 min. to get the bootloader flashed - no big deal and really easy! All the information are on, it didn’t even require to power the VESC on, just connect the stlinkv2 and follow Benjamins instruction for bootloader creation and upload under Ubuntu.

And a big thanks to you Jacob, for providing always the latest OSX and Win versions of the BLDC tool! That’s really convenient and I am sure a lot of people are very happy about it, but never giving you feedback. I know a hand full of guys using your BLDC versions here in Germany, and they’re very happy not being forced to install Ubuntu!

Just on a side note: maybe you’d like to add the missing FW1.13 file in the current OSX Version on google drive? That would be nice.

1 Like

all updated mate and thanks for the support. just a shout out if any one has a motor config file that they want to send me shoot it over, ill add it to the collection.