VESC motor detection failure - R-SPEC

Here’s the background: -New VESC out of the box 2 weeks on the shelf in the garage. -Re-soldered my own battery connector -Soldered on the included motor bullets -Plugged into my enertion r-spec 6374 -Set the BLDC software to approximate values for a 4s battery -Had bad motor detection no matter what values i played around with. -The motor “kicks” or stutters initially, then stops immediately -Then for the slow run, i get a stuttery slow crawl -Tried restarting vesc, un plugging, the usual

I am completely lost as to what to do next… Thanks for the help…

What exactly did you do in this step?

Leave your “maximum input voltage” at 57V

1 Like

Afrin, and I are working on this together. 4s battery values were things like the battery cut offs. So i changed them to suit a 4s. I also tried changing the maximum input voltage back to 57V. Motor is still clunking just as before… Still getting the “bad motor detection” text Any other thoughts/solutions???

Maybe it is you battery… your motor is probably to much demanding on the current and the battery can’t provide enough power, I have the same problem using 3S for R-spec motor.

It should be able to handle the current… I have seen people run the exact same setup with a 4s. I have an extra 4s battery, so I guess I charge it up and run them both in series. So you were having the exact same problem? What battery did you use that fixed your problem?

A custom 10s4p, I’m usually using the 3s to do motor detection and test vesc with a small 5065 motor, but on r-spec that doesn’t work, these motor are just beast.

Thanks for the tip, I give it a try when I get home. The motor does spin when I use 4s, it just jumps and stutters. When I use the arrows keys, it stutter once, then runs smooth if I hold the key.

because, when you use the arrow, your taking max 3amp, a motor detection can draw more than that

When u do the test for FOC check the resistance and inductance numbers and compare it to a known good motor that’s the same model

Bit of an update. I ran the test again this afternoon and i noticed in the real time data the fault code “abs_over_current” The current spiked at around 32 amps.

Have you tried updating the firmware on the vesc?

No I haven’t tried that yet. Is that easy to do, as I have not looked into it. My VESC is a 4.12 if that helps. I was hoping to leave firmware updates and such as more of a last option and try to fix the issues by ensuring setting/batteries/connections are correct.

It is easy, but be careful. I am sure you will find a thread on the forum for how to do it.

My vesc is on 4.18 firmware right now. Is there a more recent one??

Hi Rikki, I’ve seen the same issue when I tried to configure my VESCs using one 4S or 5S battery. “motor detection failed”. Also R-SPECs and other motors.

In my case the solution was to configure the VESC with the full 10S voltage. Before I used the full voltage I triple checked that everything was correct.

Disclaimers: I’m no real expert in VESC, but got all of my 5 VESCs working in various builds. I know that some people recommend (or used to recommend) that it’s better to configure a VESC using a lower voltage or lab power supply. This didn’t work for me.

Procedure that worked for me:

  • triple check everything will be connected properly
  • hook up battery, VESC and motor (no belt)
  • set low voltage cut-offs according to your battery pack (edited: leave upper voltage limit @ 57v according to @chaka)
  • set battery and motor amps limits to a low value (e.g. 10 amps, just to be cautios)
  • run motor detection
  • set battery amps and motor amps to desired / recommended values

One more thing: make sure that the shrink wrap on your R-SPEC is ok and cannot come loose.


Yeah I’ve got 2 4s batteries that I will hook up as soon as I get connectors tomorrow. Did all 5 of yours vesc’s have the same issue on 4-5s?

Hmmm, first I tried motor detection using a 14V or so power supply. I could set the values and program the VESC, but no motor detection. Just stuttering or not even that. This was with an SK3 6364 213kv Then used 3 4S in series for 12S to do that motor detection and it worked.

Exactly the same for another single motor build, this time with a big R-SPEC and 10S. Again tried with the power supply, then one 5S battery, didn’t work. I could read and write the values, but no motor detection.

Then the same with my hummie hubs.

So now I just use the power supply for initial hook-up, checking FW and values, setting initial values. Than use the full battery pack for motor detection as described above.

I hope 8s will be ok, because that is what i have and plan to run.

Did you change the abs max current? Should stay at 130A