Vesc problems connecting

I tried to connect my Vesc to my computer using a cable. It makes that sound sating that its connected but when I go on BLDC tool, and try to connec, it says Device not Found. Does anyone out there know how to fix this. Do I have to connect my motor to the Vesc when planning on configuring it? Is this a Vesc problem or Computer problem? Thanks in advance

Is your VESC connected to power? It needs to be.

it is indeed

Click the drop down in the tool and see if there are any other available COM channels?

tried that doesnt work

when i click the tool on the top it doesn’t show anything its just empty. may this be where the problem is starting

1 Like

Can anyone send me a direct download link from their computer to my computer so i can get riding asap

Are you on Mac or PC

PC link:

1 Like

Hey! I’m having the same problem… I have two VESC’s that I have tried and they both won’t show up on the BLDC tool. There is no Com popping up in the drop down menu. I have the VESC connected to power and it displays the blue light, then three flashing reds ones before going back to blue. I’m thinking I might try getting a different Micro-USB cable

Got my BLDC from the link above. I’m on a PC running windows 7

I figured it out now. You have to go into your Driver Update something(the app on pc) and go to the one that has something to do with COM. double click that and go to the drever tab and click on update driver. then itll say something in the end like COM3 or something like that. Exit BLDC tool and reopen it. it then says your COM in the tab.

1 Like

I’m not sure that I did it right… Do I need the VESC plugged in when I run the driver update? I’m looking in my device manager under the ports section because it has the work com there.

yah it should be connected

maybe these pics will help .

so first you connect Vesc to power and to computer. Next you open up the driver update app on pc. then you click on the ports option. double click the option there is with the COM in it.Then you open up the driver tab and click on update driver . click the automatic one and then the option from the ports will come up. after the update go to the BLDC tool and hopefully youll see the COM port avaliable

Wow thank you so much!!! I got it working! Mine was displayed under the Other Devices section.

Hey, having the same trouble connecting the vesc to the tool at a different computer. Tried your fix. didnt work for me :frowning:

Thanks for the help! I was having the same problem. ended up googling and downloading drivers for “stmicroelectronics virtual com port”

now everything works fine

1 Like