Vesc Settings for maximum potential (8S, 260kV)

Hey there fellow builders, I bought a second hand board bout I don’t really understand what all the settings do in the BLDC tool. I want to know if I’m using my full boards potential. Below are the parts. Turnigy Aerodrive SK3 - 6354-260kv 2360W max 70A 8s-10s 4x MultiStar 4s 5,2A ( 2xseries)x2 in paralel giving: 8s4p10.4A at 10c I find the board kind of lacking in the initial torque departement so I thought maybe something isn’t configurated the best way possible. Thanks in advance!


@ThomasRBK set Max ERPM to 60,000 or less to avoid exceeding VESC’s RPM limit. You motor KV is a little above the recommendation for 8S so this will help to avoid problems.

If you want more power then set the motor max to 60 or 70 and the if that still isn’t enough set the battery max to 40.

This won’t hurt the motor? Don’t wanna ruin my stuff because of this :stuck_out_tongue:

Thanks for the warning!

1 Like

That doesn’t hurt. Maybe the belt because there will be more power. And set motor min to - 60 and bat min to at least - 12.

Doesn’t this store potential power and then kills the vesc?

No it doesn’t.

But the motors produces current when rolling right? Where does that power go then?

Only when you break or give power otherwise it doesn’t in current mode.

Ooh I didn’t know that man, thanks. Can you let it produce power when not accelerating though?

Touch the break and it produces power while you break and charges the battery.

Changed eRPM to 60.000 now, motor max 50, motor min -60, batt min -12. This should be good right?

Test it and have fun

motor min looks high, i think i have -40/ -45… it will have hard breaking. I would move in smaller increments.

Changed it :slight_smile:

Hey, how has the board responded to the changes? I have the same set up on a new board and will have to change the settings on mine because it experiences the same issues with acceleration and breaking and in fact is actually an 8S battery as well with the same settings apart from I had already set the max erpm set to 60000.

Question to others here, should the max input voltage be equal to that of the fully charges battery pack of 33.6 and not set to 50 or does that not matter?

Leave it at default 57v, no need to change it.

Well then, will change that back then.

I do have a follow up question with regards to the motor max. The motors we have are rated for 70A max continuous and so if we set the motor max and min to be like 60A/-60A respectively, woukdnt that be 10 amps more than the continuous of the VESCs at 50A?

there’s more current running through the motor than what is supplied by the battery. The VESC can handle 50A continuous battery current, but you’ll never run at that current for most users. You draw ~20 tops accelerating on flats, more if you floor it with high settings.

1 Like