VESC Shutdown on full charge. (12s LIPO with BMS)

Hey guys, so I swear there was a thread solving this from a while ago but I can’t for the life of me find it with the search…

Basically, when I fully charge my board (12s LIPO with BMS) to 50.4v, 100% on the battery meter, I am finding that anytime I try to brake with a load, my VESC will restart until I have used the board a little bit (Down to maybe 98% - 97%) when it’ll start acting and braking normally. Was there a fix for this in settings? Or should I just not fully charge my board?

Thanks in advance…

I don’t know the fix, but I’m pretty sure it is along the lines of the regenatove braking is trying to over charge your battery, but the BMS is stoping it, and with all that extra energy it is shutting down the VESC. I may be wrong, but I think that was what happened to the boosted v2

Are you discharging through the BMS?

Yes, could that be it?

If your charging and discharging through the bms, then it should keep the battery from over charging during regen braking. What brand of bms is it?

Battery Supports. Would that give me an over voltage error? That’s whats thrown up on the VESC when it happens.

What is your max voltage setting on the VESC? It should be set to 57V for 12S

Post some screenshots of you settings. But jmasta is absolutely right.

I’ll post up some screen shots, I’m 99% sure I have it set at 57v though. Will report back!

Yep, was already set at 57v. Any Ideas?

Looks good to me. Really could be the BMS. Just type “faults” in the terminal tab after the vesc shut down. Don’t switch off the board on between the shutdown and the terminal entry.

Alright I’ll full charge the board tonight and post the error code. Pretty sure that it was throwing up an OVER_VOLTAGE code last time I checked. Thanks btw!

Give yourself a little bit more play in between your voltage cutoff start and end.

Because now how it is, you will most likely hit your cut end emmediatly after your start.

I would put your cutoff end around 36V

I have the same problem with the 10S space cell… I’ll check the max voltage setting and also check the error it gives me… thanks

Ok just fully charged and grabbed this:

Any ideas, not 100% sure how to read the report.

try to tune down your batt min to -15

not sure if this will solve the problem…

Have you try to bypass the bms

No change :slight_frown:

I think I’ll try this next…!

Just so you know I fixed mine. Max input voltage was set on 42. I put it on 47.5 and now it works fine! Is it the right number for 10S?


57 is the right number. This value is not to protect your battery. It is to protect the Vesc because it can only handle 60V and by 57V it has a little buffer. @jackw It is very likely that it is caused by the BMS which shuts down. But please also check with a multimeter that the battery is not above 50.4V without load.