VESC Tool & Ackmaniac Vesc Tool Mac Builds

Hi guys, several people asked how to run VESC Tool or Ackamaniac VESC Tool under mac, many suggested to install Windows through Bootcamp, but I thought it’s a bit overkill so I went and built both tools for Mac.

The only problem is that if you running latest version Gatekeeper will not allow running unidentified applications. At the moment I don’t have Apple Developer license membership so I can’t sign these applications to run without problem. But there is a fix:

You will need to open the application called Terminal which is located in:


and paste this line of code to disable Gatekeeper (allows to run apps not verified by apple)

sudo spctl --master-disable

and enter your password and press enter now it should work.

If I am missing latest version just mention me in this topic I will build and release it right away :wink:


Thank you! :stuck_out_tongue:

Nice job !

But I think there is an error in your first phrase (windows instead of mac)…

Oh thanks for notice :stuck_out_tongue:

What’s the difference with the official VT already available from @rpasichnyk repo ?

1 Like

No difference I guess :wink: I just saw people asking, so I went and made it, as I am compiling it for myself already :slight_smile: I guess there are probable every tool compiled to mac, but just lost in the posts :slight_smile:

I was able to run acks esc tool no problem only problem I encountered was the freezing after firmware update. but after that it ran with no issues

1 Like

It’s mac issue with serialport sometimes it freezes then can’t find serialport…

I can’t run it because it says macOS version might be different. What version is this for?

Ahm, minimum version is 10.11

1 Like

WOW thank you so much i hate having to run bootcamp, if it wasnt for my AEM computer for my car i use for tuning id get ride of bootcamp all together but that damn thing only works on windows

Not sure what I’m doing wrong, but I have followed the link for the ackmaniac download and when I try open it I get this message.


It’s a zip file dont know what are you doing wrong mac should support zip files :wink:

I had problems to extract the zip file. Tried it on a windows pc and made it with ignoring all error messages but didn‘t tried on Mac yet if really all files extracted

Ahm what kind of error messages? I have tried on multiple macs without a single error on extracting zip file. There was issues with ack build as I haven’t included linked QT libs inside application but I fixed it.

Vesc tool is better use the one @Pimousse linked I am bit lazy to go god lengths to relink global libs to internal ones…

You have to enable the ability to download from an unsecured site basically Max’s really only want to download from the App Store

I think his issue is either zip file is not recognised or he tries to open something wrong. @ArnhemAnt can you make a screenshot what you trying to open?

Something like …not possible to encrypt file… Unfortunately i‘m out of the office and didn’t made a screenshot. But in the end it unzipped. Don’t know if everything but will check it in the evening

Sorry for the delay. I’ve played around with this a little more and have discovered that my OS version is not supported - bugger… 02%20am

Just update your OS to El Capitan or High Sierra