VESC-tool / Motor expert please look here

Hi Guys

My APS 8072S setup acts strange - At a certain level of RPM the magnetic rotor starts to vibrate. This is both happening when going up in speed, and when throttle is totally released and the rpm just decreases naturally.

When the vibration kicks in, the power decrease until you get above the vibration point. It happens to both motor and they are new, so i doubt the problem is in the motors (unless APS deliver bad motors?).

I made two videos of the problem here.



Setup is VESC6, APS 8072S, 12S LI-PO turnigy graphene.

Hope you are able to help me out.

1 Like

The videos don’t work. Please also upload pictures of your settings.

Did you do a motor detection properly and write the values? That would be my first thing to check.

Yep - Motordetection done by wizard.

Did a lot of different setups with wizzard motordetection. Normally i have no problems.

I’d dbl check your belt tension, might be pulled to tight and why the housing is out of alignment and is why your able to pull through it at higher revs cause it stretches out

Videos work now. That is indeed very odd! You’re not hitting anything and are your mounts solid? Is it only the can vibrating or the whole thing including mounts?

It’s a gear drive. But that’s a good point, vibrations could be coming from the gears.

1 Like

Do the motors act the same under no load?

:persevere: just started typing away, usually only seen issue with belt drives.

Could you specify what part of the video you think is strange? Is it the exact same behaviour under load? Or didint you ride the board yet? What battery are you using? What limits are set in VESC?

This is with No load. Motors are spinning free in the videos, but on road with gears IT is exactly the same, just Louder.

Brackets are rock solid and had no vibration. IT is only the rotor part that vibrates.

Setup is 12s lipo, vesc6 and 8972s

Turn Up volume, and you Will not have any doubt about which part of the video is wrong :slight_smile:

In the near video you are able to see the rotor “flexing” at a cetain rpm level :frowning:

I asked if the behaviour was the same under load. The vid is obv. zeroload. The mechanical resonance RPM maybe sounds and feels scary, but its quite normal. Did u ever look at a washing machine spinning up? At a specific RPM it looks like its gonna take off, then it just settles down.

Exactly the same under load. Powerloss and a terrible Sound :frowning:

Alright then, back to the remaining questions, what are your VESC settings and what are you supplying the motors with?

For the third time 12s lipo 6000mah graphene :grin::grin::grin:

Vesc settings is standard. Which do you want, then i can a screendumb :+1:t2:

It could be the motors cans are imbalanced. If you’ve taken a motor a part, sometimes you’ll see some little blue dots of putty inside the magnets spaces. These are used to balance the motor, along with vibration detection tools to figure out where the imbalance is. The higher the speed, the worse the imbalance gets because the centripetal forces are higher at higher speeds.

Can’t say if this is your case, I would double and triple check all software/hardward first before jumping to this possibility. But I have strong feeling this might be your problem.

@DK-Odense rerun motor detection with a higher duty cycle. :slight_smile:

That sound is from a bad detection. And the controller having bad math trying to properly read motor position. The noise is two magnetic flux linkages crossing causing the can to harmonize.

A redectection with higher duty cycle will help, or running sensored should eliminate this(hybrid doesn’t count)

1 Like

Hi Deckoz

I have now tried with different duty cycle settings in the detection part, going from 0,3 to 0,9 without any results. I tried with both motors, and the problem is the same :frowning:

Is it possible that motor wizzard just dont work on these motors?

It could be possible @DK-Odense

Try resting to a defaults config. Avoid the motor wizard. And go to the bldc tab and run a detection manually with .05 .10 or 0.15

This exact thing happened to me with my 6374 motor last year. (There should be an old thread on this as well.)

I opened up the motor and it looked as if some of the magnets were slightly touching the stator, as there were very light marks on the magnets.

I couldn’t see why this was happening at the time, so I kept riding the board. After a while though the noise kept getting worse and changed, and eventually the motor broke down totally and it turned out that some magnets had come loose, ie I could move the with a screw driver as the glue had let go.

I got the can replaced with a new one, which solved the issue.

Here’s my old thread

If you search for “screeching motor” you’ll find a couple of others that had the same issue with this noise at a certain rpm that was due to magnets coming loose.