Starting Tips | Ask Questions | Introductions | Categories

Voltage sag? Board cuts out on full throttle during acceleration

So I finally got my board up after months of work, and after riding for about a week (25 miles?) I’m now having an issue where my VESC-X restarts on full acceleration. If I accelerate more slowly then it does fine. It hasn’t shown this issue until all of a sudden. I’ve included my settings. I’ve seen setting the “Max input voltage” to 57V is that recommended? Is that the Motor Max setting (just to be sure)?

I’m terrified I’ve killed my battery.

Motor max/min - 60A/-60A
Battery max/min - 30A/-12A
Absolute Max - 130A

What battery are you using? Liion Lipo? Max Discharge? There have also been cases of bad Vesc x that have cut off due to low voltage from a bad resistor or something along those lines, and you may want to double check with the seller who sold you it

I bought most everything from Enertion (all except the motor, 6355 190kv TB) it is the Spacecell 4 (10S4P Li-ion), Absolute Max is 130A.

whats your battery cutoff start/end?

Shoot, I can’t get back to my computer right now. But it is the default, I haven’t touched those settings at all.

I’ll send them over the second I’m able.

My guess is that punching the throttle is causing too much sag and it goes below the threshold for battery cutoff.

Any idea why it would start happening now? I’ve kept my riding style pretty consistant. Have I damaged the battery in some way?

It’s more likely you’ve damaged the VESC-x, but hard to say. Seeing all your settings would help.

Here we go!

Try adjusting your battery cutoff start/end to something really low for testing (like 10/10) to see if you still have the problem.

Could you post your other pages as well? (BLDC, Advanced)

Did you do motor detection? Those values look like they’re default.

I didn’t for that screenshot but here it is after a motor detection…

You didn’t write the config for it. You have to do detection to get the values, hit “apply” or write the fields in manually, then hit “write config” to write it to the VESC

Ah, I thought you just wanted to see the readings, I had done a detection and apply before, but I’ll do it again.

Well you have to apply AND write config. Simply “applying” doesn’t do anything besides write the numbers in the appropriate fields for you.

Applied and config written!

Cool, have you tried adjusting the battery cutoff voltage to see if the problem persists?

I did, I set it super low 10/10 as you suggested, put one foot on it hit full throttle and same issue.