All new 2019 VESC-Tool release

All while constantly referring back to your aforementioned “bestest most highest quality super awesome amazing” device, which…runs…android?

But you’ve finally brought up a point worth discussing. But I fear we’re way off topic for the OP. Happy to hear your thoughts in pm.

You can send me a purchase order and I will stroke your apple ego all day long. Until then, no thanks.

No worries, I’d be afraid of facts too if all I spoke was nonsense. Take it easy.

1 Like


1 Like

This is just a wild guess, but think what if Frank uses the iPhone too? :upside_down_face: Then he needs to have a skate phone and a Benjamin phone®™, the phone you take with you when you meet Benjamin IRL. And it can’t be cheap (too suspicious!). Otherwise someone will not be happy! :wink:

1 Like

I have a skablet and a skone, no iSkate.


I would have bet my left arm that Frank doesn’t use an iTurd.

Dearest Frank

I have noticed some odd behaviour setting up the V4 VESC. Two weeks ago I installed V3.56 and ran a full setup setting the motors up for FOC, all went well. Today I setup another v4 pair of VESC’s with 3.57 exactly the same and this time I could tell straight away they were in BLDC mode. A quick check on the mobile VESC tool confirmed and I was able to switch it to FOC. Also I noticed reading the data from the VESC’s they were not the values I had set for currents in the actual desktop tool. The strange thing is my friend also had a similar thing happen to him on the same firmware, after going through FOC setup his was setup in BLDC also. @trampa

I can confirm that. Strange behaviour with the latest FW. I set up my new Landwheels and at first I thought they had some problems, checked in the VESC Tool and voila, they were set for BLDC :slight_smile: When I change it to FOC they worked like a charm though :slight_smile:

I will check that. If there is an issue, it will get fixed soon.

1 Like

Check the change log.

Use default F_SW for Hardware after autodetect FOC.

RT Data logging is new BTW.


Now I see that, but what does it mean exactly? It sounded like a description for a bugfix :wink:

HW4.12 is set up in BLDC after FOC detection

:smiley: Ok, thats basically a very good thing since there are many 4.12 based ESCs out there that don’t work well in FOC but a better description would have been great. The new (nice) App denies to work properly with old FW most of the time so communication about major changes might need to improve :slight_smile:

yeah but how does that help those of us that want to setup FOC on V4.12 hardware?

edit, also does data logging work now? it wasnt working in the last version

It doesn’t prevent setting up FOC, it just defaults to BLDC to prevent damage to those who don’t work properly in FOC :wink:

which is basically preventing you from setting up in FOC is it not? I choose FOC and it gives me BLDC. Not really what one would expect.

Also Frank, When setting up the firmware update for the hardware it was supposed to update over CAN, which it did, but then when I went to do detection it told me that both VESC’s had to be on the same version firmware? I connected to the slave directly, checked the firmware which indicated it had been updated but I decided to do another firmware update regardles. Then I plugged back into the master and detection worked.

Sometimes it takes another try when that message appears, I guess its some hickup in CAN communication. I had these a lot at the beginning of the 3.5 line but the latest versions seemed to have improved that. The best thing would be a popup window telling that “Detection was successful, however, since you run 4.12 hardware you were defaulted to BLDC. If you are sure that your hardware is able to do FOC feel free to switch it, the proper settings were made already”


yes I agree that would be much better, doing it without a prompt is a bit silly imo

1 Like