The iBoard | Loaded Vanguard | SK3 6382 168kv | 10S Lipo | VESC ESC | 83 mm Enertion Powerwheels

today I set up my sk3 6374 for my vanguard build and instead of a keyway, I just drilled 2 small dimples where the grub screws are located in the pulley. the pulley snaps right into the correct place and it feels pretty solid (2 grub screws in 180° layout). maybe try that next time, seems less invasive and a key isnt REALLY needed - was running my trampa also without one.


what kind of drill did you use? That hardened steel was a pain to get flat for my grub screw.

just a fairly good metal drill. I was using the drill press of my granddad and it took me a while to figure out the trick: if you go super slow and careful, the drill will dance around the point where you want your dimple - what youll have to do instead is aim well with the press, and then lower the drill fairly quickly and with some force - youll get the initial scratch that keeps the drill in one place. :relaxed:

1 Like

a punch can really help with this. All you need is a small divot to start - also starting with a smaller drill bit then going larger might help.

try one of these first next time and it should help:


Got it all sorted out! Belt drive now works perfectly. Took the board out for a spin, and it worked great! - for a while at least. I rode the board for about 5 minutes, not even hard because I’m still new to long boarding, and boom, DRV8302 error. It just silently cut off while cruising. Took it home and hooked it up to BLDC tool, and it says DRV8302 error :sob: Why did this happen? I set everything up with care… And I haven’t touched FOC… @elkick I shot you an e-mail as well, and I hope you can help. :slight_smile:

1 Like

Did you do a proper motor detection? Sounds like a horror story: get new board, ride for 5min, have broken VESC :frowning:

was the vesc dead or did it just restart? :dizzy_face:

Yes! I did proper motor detection, it worked flawlessly! The calculated kv is even pretty close to 168kv… No wire has jumped off or anything :frowning: I’m still able to connect to the VESC, and do various readouts, but when I try to accelerate, it says DRV8302 error…

1 Like

so its still booting? whats the DRV8302 error? you can type “faults” or “errors” (not sure anymore) in the BLDC gui console to get an idea why it has the error (like under voltage, over current, xyz).

I get this when I’ve tried accelerating once:

Sorry to hear that! I’m load testing all the VESCs before sending them out, so it also might be a configuration issue. DRV fault doesn’t mean that the DRV is blown automatically, but of course it can be an indication.

Can you please post a picture of the motor config, the BLDC tab and the VESC (if possible) please? Also, what BLDC Tool version are you using, where did you download it and when? I’m asking this because there have been faulty versions of the BLDC tool 2.17 and 2.18 around for a few days which can cause troubles as well.

Of course! I downloaded it on May 25th from and I believe it’s the same version as the one on the site right now (2.17-2.18). The VESC is running firmware 2.17. Motor config:

BLDC tab:


Wasn’t this myth busted by Jacob? He said he does not experience any issues and it looks like only people that don’t even know what VESC version they are using are having trouble - so it’s most probably user related.

Downloaded a new copy on and also updated the firmware on the VESC to 2.18. Still a DRV8302 error.

No, the first versions uploaded around 25th May were containing bugs which were causing different problems. There als were some customers from @chaka who had issues and failing VESCs based on this!

@fraannk, those values seem to be realistic and the VESC is not showing damages (those marks at the FETs are normal due to the shrinking of the tube, so no problem). Can you please check all the soldering connections again, they might have come loose due to vibrations. You can remove the shrink wrap for this, no problem. Also please check all the cables going to the battery and to the motor. If possible test with another motor too (just doing the motor detection). It also could be a motor related issue, shorting cables or so.

In any case, we will solve this - I want to see you riding on your board! :slight_smile:


Your settings might have caused your DRV to fail. Your motor current max and min should be 80A and -80A (as per SK3 6374 data) and your max ERPM should be limited to max 70 000.

The VESC draws a curve with the motor max-min, and limits the output with the batt max. It is very important that the VESC has as much good information about the motor as possible, including motor detection. Bad setting can result in a voltage spike that can be fatal to the DRV

@elkick I checked all the connections, and they look great. Hmm, I have a very teeny tiny outrunner motor, would it be possible to use that?

Limiting the amps to the motor, would that not just make it even safer? And just sacrifice performance?

1 Like

no, this is not limiting the amps, the BATT max limits the amps. the vesc uses the motor max-min to draw a current throttle curve, it stays within this curve with batt max-min. if these values are off, this is when damage can occur.

Okay. For my SK3 it should be on 70a then. It says that on HK. :slight_smile:

1 Like

so your motor settings are not that off, but max ERPM can damage the drv, i went through 3 vesc before understanding this… but then again, you said you were cruising, i destroyed my vesc during some bench tests at full throttle

1 Like